VMWare vSphere Perl SDK für Ubuntu 10.04

Für ein Nagios Modul habe ich mir die neuste Version von Vmware’s Perl vSphere SDK runtergeladen und wollte dies installieren.
Normalerweise ist die Installation von Vmware-Produkten ja keine grosse Sache, da kommen immer so nette Autoinstall-Scripts mit – genau wie auch dieses mal.
Also schnell heruntergeladen, entpackt und gestartet:

wget https://download2.vmware.com/software/sdk/VMware-vSphere-Perl-SDK-5.0.0-615831.x86_64.tar.gz
tar -zxvf VMware-vSphere-Perl-SDK-5.0.0-615831.x86_64.tar.gz
cd vmware-vsphere-cli-distrib
./vmware-install.pl

Doch irgendwie kommt da ein interessanter Fehler:

Please wait while configuring CPAN ...
Please wait while configuring perl modules using CPAN ...
CPAN is downloading and installing pre-requisite Perl module "Archive::Zip" .
CPAN is downloading and installing pre-requisite Perl module "Class::MethodMaker" .
CPAN is downloading and installing pre-requisite Perl module "UUID" .
CPAN is downloading and installing pre-requisite Perl module "Data::Dump" .

CPAN not able to install following Perl modules on the system. These must be
installed manually for use by vSphere CLI:
UUID 0.03 or newer

Das Problem sind einige fehlende Abhängigkeiten, welche nicht automatisch nachinstalliert werden. Also machen wir das manuell:

apt-get install libarchive-zip-perl libcrypt-ssleay-perl libclass-methodmaker-perl libdata-dump-perl libsoap-lite-perl perl-doc libssl-dev libuuid-perl liburi-perl libxml-libxml-perl ia32-libs

Nun sieht das ganze schon besser aus:

The installation of vSphere CLI 5.0.0 build-615831 for Linux completed
successfully. You can decide to remove this software from your system at any
time by invoking the following command:
"/usr/bin/vmware-uninstall-vSphere-CLI.pl".

This installer has successfully installed both vSphere CLI and the vSphere SDK
for Perl.

The following Perl modules were found on the system but may be too old to work
with vSphere CLI:

Compress::Zlib 2.037 or newer
Compress::Raw::Zlib 2.037 or newer
version 0.78 or newer
IO::Compress::Base 2.037 or newer
IO::Compress::Zlib::Constants 2.037 or newer
UUID 0.03 or newer
LWP::Protocol::https 5.805 or newer

Also müssen noch rasch die Perl Module aktualisiert werden:

cpan-outdated -p | cpanm

Für alle die noch kein cpanm oder cpan-outdated haben, zuerst noch:

curl -L http://cpanmin.us | perl - App::cpanminus
cpanm App::cpanoutdated

So, und nun sind wir bereit!

Ein Kommentar bei „VMWare vSphere Perl SDK für Ubuntu 10.04

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.